Links Relacionados

Pesquisa

segunda-feira, 4 de dezembro de 2006

A migração: "Windows to Debian" parte 1

Olá pessoal apartir de hoje eu vou começar uma sessão sobre o Debian, que é a minha nova distribuição.

Depois que eu, Jhou e Piltz fomos para a feira de informática que aconteceu aqui perto, em foz, e também depois de ver 3 palestras seguidas sobre o Debian, nós decidimos mudar o nosso sistema para Linux, e dessa vez "DE VERDADE".

Começando hoje vou contar como foi o início da "migração".

Primeiramente nós estavamos preocupados em baixar 15 cds de instalação para o sistema, e o Jhou que é o cara com a ADSL mais "Rápida" entra agente, estava sem ela nesses dias. Ía sobrar pra mim baixar com a minha de mizeros 250K. Mas fui tentar.

Logo quando comecei a me informar sobre o sistema entrando em alguns servidores de IRC já logo de cara fiquei facero porque me disseram que eu não precisaria baixar todos os CDs, mas sim o primeiro, que já estava de bom tamanho. Pois bem, baixeí-o, e fui logo gravando cd assim que o download acabou.

[ Os primeiros "medos" ]

Comecei a instalação, e como já fui avisado de que ela não seria nada "comum" como em outros sistemas, já estava esperando o pior. Minha principal preocupação era com o particionador dele que eu não sabia aonde eu ia mexer nele, e nem como ele era. Mas uma hora ele apareceu, numa tela de terminal mesmo, e com suas opções normais de qualquer outro particionador.
Escolhi a partição que eu queria formatar, coloquei o ponto de montagem, e tudo tranquilo.

[ Os primeiros problemas ]

Depois de algum tempo, não muito, a instalação dos pacotes se iniciou, nesse momento eu descobri o porquê de falarem que a instalação é difícil. Resumindo a opera toda, aquele sistema de seleção é muito complexo, nada intuítivo, demorei um tempão pra me entender com ele, lendo o help (pra variar). Assim que escolhi os pacotes, o sistema resolveu fazer uma verificação de segurança nos pacotes, provavelmente pra ver se não havia atualizações. Como minha internet não estava configurada como DHCP, tive problemas nesta parte, o sistema tentava conectar mas o host não respondia (óbvio), depois de alguns minutos a instalação continou.

[ Finalmente a instlação termina e os problemas continuam... ]

Alguns minutos depois a instalação acabou, e lá estava eu de frente com o terminal, e já de cara tentei iniciar o X, e adivinha. NADA!. Falava que o pacote não estava instalado. E eu recordava muito bem de ter selecionado ele, assim como o gnome e kde, na seleção de pacotes na hora da instalação.

Voltei para o meu Windows para pesquisar como resolver esse problema. Encontrei um monte de sites com o meu argumento de busca no google, mas nenhum parecia resolver o problema.

Nisso eu pensei em instalar o pacote via apt-get, mas para isso eu tinha de configurar o sistema para conectar via pppoe. Voltei para o sarge, e tentei configurar o sistema. levei sorte do sistema ter instalado o pacote pppoe. Rodei o pppoeconf, configurei certinho com os meus dados e salvei a configuração. Fui testar se estava conectado e adivinha, NADA, de novo :(. Nessa hora lembrei que o Kurumin tinha aquela opção "Conecta, mas não navega", muito bem, fui atraz deste script no Kurumin, peguei meu live-cd iniciei o sistema, copiei o script, não só ele mas todos que estavam dentro da pasta de scripts do sistema. Antes de fechar a sessão resolvi escrever em um papel aqui todos os comandos que eu ia precisar.
Fui para o Sarge.
Executei os comandos que estavam naquele script e na hora do teste, adivinha, AEEE!! :), a internet funcionou.
O script pra quem tiver algum problema relacionado é este aqui:

chmod 666 /etc/resolv.conf
cp -f /etc/ppp/resolv.conf /etc/resolv.conf
chmod 666 /etc/resolv.conf
poff -a
ifconfig eth0 0.0.0.0
pon dsl-provider (dsl provider é o nome do provedor, verifique, /etc/ppp/
route add default ppp0


Se tiver algum problema com o DNS, eu colocava esses aqui:
200.184.26.3
200.184.26.4
# ou
200.199.201.23
200.199.201.24
# um desses devem de funcionar


[ A instalação do X ]

Com a internet funcionando eu podia fazer o download dos pacotes do X.
Primeiramente é bom verificar aonde o sistema está fazendo o download.

Dê um nano /etc/apt/sources.list

Se você quiser apagar tudo, fique avontade, se estiver com medo de fazer isso simplesmente comente as linhas com o "#".
no final do arquivo coloque:
deb http://ftp.br.debian.org/debian main contrib

No lugar da versão, especifique a sua, stable, etch, unstable, etc.

Feito isso, no terminal o comando para o download do sistema base X é este:

apt-get install x-window-system-core

Espere o download acabar e você tem um sistema X instalado.
Aqui na minha instalação eu tinha selecionado o KDE e o Gnome, como sendo os ambientes visuais, quando rodei o comando startx o gnome se atropelo na frente e inicou.
E finalmente eu tinha o sistema instalado, com um ambiente gráfico.

[ E o KDE ? ]

Eu, como a maioria dos usuários linux, prefiro o KDE como meu ambiente gráfico. Tentei inicia-lo e não obtive sucesso.
Resolvi usar o mesmo método que eu tinha usado para o X. Baixei o KDE.
O comando é este: apt-get install kdebase
Isto te dá um sistema base para rodar o sistema sem muitas "firulas".

E o problema agora: "Como inicar o KDE ?"
Eu não tinha idéia por onde começar, eu torcia pra que ele se "infiltrasse" sózinho dentro do X ali e iniciária normalmente.
Mas não deu certo.
Pesquisei na internet e achei duas soluções.
A que eu testei e deu certo foi essa:
Digite no terminal: echo "exec startkde" > ~/.xinitrc
A segunda solução é esta (não testada).
No terminal:
startx `which startkde`

Feito, meu sistema estava rodando e pronto para que eu começasse a mexer nele.

[ A mudança de stable para testing

Depois de uma pesquisa e a descoberta de que eu teria alguns problemas na tentativa de instalar o KDE 3.5, resolvi falar com algumas pessoas que entendem do assunto. Entrei no server (irc) do Debian e conversei com algumas pessoas e eles me orientaram a baixar a versão "etch" ou testing, que o KDE 3.5 vinha por padrão e me informaram que o sistema já estava bem estável porque ele já está quase sendo jogado pra stable.

Muito bem. Baixei o etch, algumas horas depois estava eu instalando-o.
Depois da instalação do sistema, que por sinal ocorreu tudo bem, fui checar minha internet depois que eu a configurei no pppoeconf, e estava funcionando certinho, sem comando adicional nenhum.
Baixei o KDE pois não consegui instalar ele pelo primeiro CD. Mas a instalação ocorreu tudo certinho.

[ Finalizando o primeiro post. ]

Depois da instalação resolvi "emperequetar" o sistema, visitem o site: Kde-Look

Por enquanto o primeiro post tá bom até aqui.

Na parte 2 eu vou tentar mostrar algumas coisas sobre: compartilhamento, iptables, atualização do sistema.

5 comentários:

Anônimo disse...

Parabéns pela iniciativa cara.

Realmente quando se muda de Windows para Linux, vc sente algumas dificuldades devido ao ficio que temos com a facilidade do Windows, mas com o tempo vai ver quanto recursos a mais temos com o Linux.

Bom se quiser no meu blog tem uma passo-a-passo de instalação do Debian pelo Netinstall com a interface gráfica, se quiser dar uma olhada lá.

warlinux.blogspot.com

E tiver problemas pode procurar que se puder ajudar, farei com boa vontade.

Abraços !!!

E bem vindo ao mundo Livre

Nelson Junior disse...

Esqueci de colocar meu nome do comentário acima, foi mals.

Falow

Sidney Zanetti disse...

Bem legal o texto!
Uso o Debian aqui em casa há 2 anos e meio e gosto muito dessa distribuição.

Duas coisa...
A primeira é que você não precisava selecionar todos os pacotes... =)
você podia deixar ele insalar o básico e depois mandava ele instalar o X... porque para quem está começando... é muito ruim mesmo o aptitude (selecionador de pacotes da instalação).

A segunda... é quevocê não precisa ter executado todas as linhas do script "Conecta mas não navega"... apenas essas duas é o suficiente:

# route del default;
# route add default ppp0;

Parabéns pela iniciativa!

sillent disse...

sidnei...
entao, na hora da instalação eu tava digitando tudo que me vinha na cabeça, e tudo que eu lia por ae ahuiahuiua

Até eu testar qual comando era o necessário eu ia demora mais ainda o//

mais com a sua dica ae eu vo da uma atualizada no texto \o/

Newto disse...

na boa, foi dificil... mas o will pensou nos comandos e foi tentando...
agora tá lá
com splash screen icones e tudo mais \o
boa explicação will... por partes ainda ^^
|Newto|